Unable to Play Since Patch 1.76


#1

Hey guys!
So I am a constant Diamond Rank player who has been playing Duelyst since January 2016. Since I am a high school student and don’t have a proper PC, I have only been able to play on the Chrome web client (play.duelyst.com). Up until very recently, the game has been running smoothly, with only minor bugs caused mostly by connectivity issues. However, my chromebook has not been running the game properly since.

THE ISSUE
Every time, I open the game, it gets stuck on the black loading screen as shown in the screenshot.


The game refuses to load past this screen. However, the Duelyst cursor has been loading.

I’m not sure what the issue is entirely, but here are some steps I have taken thus far:

  • I have contacted the Duelyst support team. They have notified engineering of the issue, but nothing has been communicated back to the support team.
  • I have tried clearing my cache and cookies; no success
  • I have updated my Chrome to the latest version
  • My Chromebook DOES have an administrator, so my school may have implemented a firewall blocking it. However, they would have had to do it at the EXACT time the patch came out as I was playing when the patch came out, shutting down my game.

INFORMATION ABOUT MY CHROMEBOOK
Chrome version: 54.0.2840.101
Chromebook Model: Dell Chromebook 11

FINAL WORDS
The Duelyst community has been so friendly from the beginning of the beta. I’m really in love with the game, and I’d love to play again (and get that tiger skin!!!). If anyone has any ideas or works for CPG, please reach out to me. Just drop a comment so we can work together to help solve this issue for myself and other Chromebook users.

Thanks!
Tellmywife


#2

Yea i’m actually in an identical situation, and its really frustrating because i was hoping to pursue a higher level of play (S-Rank) in the coming months but since the patch my Chromebook does the same thing when i try to access the page. I really wish CPG would at least give an explanation as to why this is happening.


#3

Hi – Same problem with my chrome book. Fortunately, also have a work PC I can play on… Duelyst is work, right?


#4

Ya. CPG has also been completely unresponsive.


#5

I didn’t make to big of a deal about this before because I thought it may have been an isolated incident, but now I’m pretty upset with CPG knowing this is an issue and not even acknowledging it.


#6

Try reaching out to their technical support and on Twitter. The more pressure we put on them, the quicker they have to respond.


#7

believe me when I say I’ve tried.


#8

I just cant believe they dont have better tech support XD


#9

I know, I’ve tried contacting their tech support before and the service they have it setup in makes it feel like it’s not even CPG your contacting.


#10

Bumping this…Just opened my Chromebook tonight to play for the first time in a few weeks, and got stuck on the black Duelyst screen. Glad to see I wasn’t alone, but also sad to see that I wasn’t alone. Interestingly enough, I also have Linux loaded on my Chromebook, and the web app also fails in that environment, so it doesn’t look like it’s something related to ChromeOS specifically. However, I can load the web app fine on my windows PC.

Any other Linux users able to confirm that they can’t load the web app?

Hopefully this gets fixed with the upcoming expansion/update…


#11

I’ve been getting the same blank screen on load as well. I can HEAR the game running in the background, and moving the cursor around indicates that the game has loaded and I’m mousing over menu items, but everything is black.


#12

If any of you have twitters, be sure to post about this.


#13

Got a new Chromebook and was really excited to play and then i come across this maddening issue…SWASWSCYUGVIUOHBIUVXYTDCRX

i have been scouring the internet for solutions and it does very much seem to be a Chromebook issue and i feel better knowing that there are more of us suffering with this issue

hopefully the techs are on it and trying to fix the issue however from the radio silence it seems that they don’t care about us or it could be a bigger problem than expected