The game does not show cards and breakdown (spells/units/artifacts) during draft in gauntlet


#1

Description

Cards and breakdown (spells/units/artifacts) don’t appear anymore during draft in gauntlet on the steam client.

Operating System:

[Windows]

System Specs:

[Intel Core i5 /GTX 560 Ti/ 12GB]

Game Client:

[Steam]

Bug Report Details

Steps to Reproduce:

  1. … Play gauntlet
  2. … Start drafting something
  3. … Despair as you have to remember each single pick you made.

#2

Same on standalone Windows client @galdred if you can update your message title, it’s not Steam only.

You have to hit the “Back” button after every card choice and then come again to Gauntlet to see list refreshed.


#3

Thanks for the workaround!
It is not very convenient to do it this way, though :slight_smile:


#4

Still not working today, very uncomfortable.


#5

I’m having the same issue in the past couple of days.

I’ve tried Windows Steam and Mac Standalone they are both affected.

Have to constantly go back to refresh card list sucks.


#6

We are aware of the issue and we are working on a fix. Apologies for the inconvenience this is causing :frowning:


#7

Fixed on next patch, end of the month, they said.