Duelyst Forums

T2k5's helper scripts


#122

One last question. To keep it on forever should I check the preserve log? Thanks.


#123

What do you mean? If you load them through the devtools, they will only stay on until you close play.duelyst.com. You’ll have to do it every time you open the page.


#124

Hey t2k5, I just opened a Shimzar orb, and the Orb stat script showed some weird numbers. After I restarted Duelyst it didn’t happen again, but I thought I’d let you know.


#125

That’s because you had disenchanted cards between openings. Always press the Reset Orb Stats button if you’ve disenchanted, crafted or received gauntlet rewards before you open more.


#126

Streamers ahoy! I made a quick card data API with Nightbot support, since DuelystDB is so slow to update the cards https://duelyststats.info/scripts/scriptlist.html#scriptlist-api, will update these within a couple of hours (usually minutes) of the game getting patched.


#127

Also made my own simple decklist service, which will always have up to date card data. Import / Export support added to Collection enhancements. Select the bottom option from this menu to export:

Note that this is not a deckbuilder (yet :wink:), only a quick way to import and export decklists when DuelystDB and Manaspring haven’t updated.

Sample of how it looks: https://duelyststats.info/scripts/decklist.php?deckList=MTo0MDEsMzo0MDUsMjo0MDksMjo0MTQsMzo0MTksMzo0MjAsMzo0MjEsMzoxMTAwNCwzOjExMDYwLDI6MTEwNjQsMzoxMTA3NSwyOjIwMTEyLDI6MjAxMTcsMzoyMDEyNCwyOjIwMTU3LDM6MjAyMDY=


#128

Hi!

I am unable to see the deck tracker (all the other scripts appear to work). I am on Windows 10 and Steam. Is there a compatibility issue with the deck tracker?


#129

There’s some weird, and most likely system-specific, issue with the deck tracker. It works fine for most people, but some don’t see it at all. It may even pop up for you at some point, but I haven’t found any solution to it yet.


#130

I just wanted to also say that I am having an issue similar to @thejeremy. I am running on windows 10, but not through steam. I know you said here and on Reddit that there are " some weird, and most likely system-specific" so although I can’t provide any insight myself as to why its not working, I figured having more data could potentially help you. Also, all the other scripts work perfectly, it is only the deck tracker that simply does not show at all(I’ve tried manually adding it, as well as through the script installer). I hope you can fix this soon because I am really, REALLY loving all the other scripts. Great work man, really.

Edit - Maybe these images will help. The first image is just me opening up the dev tools right after loading up the game and it comes up with this yellow text error and a yellow triangle “!” next to it. I saw on a Reddit post where you said to paste the script directly into the console in the dev tools like it says in the instructions for a single game launch, so the second image comes from directly after trying to que for and finding a match, and trying to paste it in. The third comes from after being in a match an pasteing it in, and the forth image comes from pasting it into the launcher before launching the game. Maybe I’m doing it wrong all together but I tried each way to try to get it to work. Idk if any of the error messages will help or not, but maybe they will be useful in understanding the situation.

2nd Edit - Also, when I launch Duelyst, a small window pops up saying “Fatal Error” and some small text beneath it. But it disappears almost as soon as it appears. Duelyst launches a second after it disappears, but this little window always comes up first for a fraction of a second. I can never seem to make out what the smaller text says since it goes by so quick. I’ve launched Duelyst multiple times and its done it each time (since I’ve tried using the deck tracker script). Again, I have no idea if this information is useful to you at all, and maybe I’m just wasting your time, along with anyone else reading this. But I really do hope it helps in some way (Apologies if I am).


#131

The first image is normal, the game generates 3 different deprecation warnings when it starts.

The “maximum call stack reached” stuff is ONE of the causes why it doesn’t work on some machines. Basically when your computer is under heavy load or is just old / not very powerful, the call stack size gets limited. I got this error on my work laptop when I had almost all memory reserved, but it won’t appear under normal load. There’s very little I can do about that one, since the decktracker has to parse through ALL console messages to find the ones that are relevant for game-states. There are other, more mysterious cases of it not working, where the call stack error won’t appear.

The launcher is not the game yet, so there’s no point trying to load stuff at that point.


#132

Hey there, I tried using the deck tracker script using both the installer and manually adding it and it does not seem to work. Does the game need to be on full screen or does it work on windowed mode? Thank you.


#133

It doesn’t work in practice mode and, as you can see if you read above, it doesn’t work on some computers due to weird reasons. :confused:


#134

I saw that it doesn’t work in practice mode. I guess it just doesn’t work on my comp. Thank you though.


#135

Thank you for all these awesome scripts!
I have one question:
Is it possible in any way to edit the viewport zoom level?

Pixel Perfect is just i bit too small, while Best Fit is a little too zoomed in for me, it would be great to have something in the middle between these two.
I would love to have such an option (and please don´t say play with Chrome :slight_smile: )


#136

Well, I haven’t changed anything from today since yesterday when i made that reply earlier about how it wasn’t working for me, but now its working like a charm. I was pleasantly suprised when i launched into a game and the deck tracker was there. So Idk what happened, its the first I’ve launched Duelyst since yesterday, so yay i guess. Also, thanks again, love the scripts.


#137

Hello,

Is there a way to make templates for deck tracker that won’t be overwritten by any update, especially when using FineNerds’installer ?
Some way to have your templates in a separate file and have them loaded on the side maybe ?


#138

You can use the .getScript method locally. Just save whatever you want to a separate .js file, then .getScript(file://path/to/file.js, function(){});


#139

Yeah sure, but it will be overwritten every time I update, didn’t it ?

I mean, there is not (yet ? :stuck_out_tongue: ) a method like : put your templates in this directory and they will be loaded automagically ?

Cause it would be handy :rolling_eyes:


#140

No, CP hasn’t implemented any sort of support for mods. The closest you can get is to make a separate file elsewhere, which you’ll then $.getScript in, saves a few lines. :stuck_out_tongue:


#141

What I meant was, maybe if you (please, pretty please :heart_eyes: ), in your scripts, implemented this feature with a fixed directory path (something like “.counterplay/yada/yada”), people will just have to :

  • on update, user installs your wonderful tools with magic installer
  • dump templates into the proper aformentionned directory
  • on load, your script will parse the directoy and load extra templates (if any available)
  • profit !

No tinkering/devwebtool/editing stuff needed, super fast, super simple :slight_smile:

I’m asking for that because on my screen, even the 4rth template (small stacked) is taking too much room, no matter which place I move it with R, it’s most of the time overlapping something useful in the UI :confused: