Prismatic generals not showing up in the collection list


#1

Hello guys!

Title. I already have maximum faction level (Vanar). I’m comming back from a little hiatus so I dont know if something changed about this, but it used to work fine before. Anyone with a similar problem?


#2

Go to the options of the collecxtion screen and enable “Prismatics” and “All Cards” (or “Core Set”).


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.