Installer fails


#1

Description

I download the installer, which always gets interrupted during the latter half, and the installation fails for no discernable reason.

Operating System:

Windows 10

==================

Bug Report Details

Steps to Reproduce:

  1. Download Installer
  2. Run Installer

EDIT: And, suddenly, on like the 10th try, it works. WTF? I was just trying it again so I could grab the log to post here, in case it might help, but it decides to mess with me and suddenly work… That’s a thing.


#2

Do you play games on Steam? We have a steam version coming soon that should work better in terms of download connectivity.


#3

As I said in the previous post’s edit, it suddenly started working for no apparent reason. I might consider using the steam version later, as I do like my achievements, but for now I’ll use the client.

I was just hoping to both solve my problem and keep it solved so no one else is put off by a weird inexplicable bug. It’s especially weird because I had Duelyst on my older crappier laptop and it worked just fine, so I expected it to work on my new nice one even better, so when the exact opposite happened, imagine my surprise.