Game on client lag as hell


#1

Description

When I try to play on the client the game lag like hell in the menu and even worst in game, just like I didn’t have enough ram to run the game, I know I can run the game because I use to play on client for several month , also the game run just fine on browser. Tried to reinstall the game but it doesn’t work , also my computer does a weird thing when I click on the launcher (see screenshot):

I have this problem since the end month patch of June.

Operating System:

Windows 10

System Specs:

Intel Core i7-3632QM 2.2ghz/3.2ghz
NVIDIA geforce GT 730M
4 GB DDR3 memory

==================

Bug Report Details

Steps to Reproduce:

  1. Launch the game on the client

#2

Regarding the screenshot, I think that’s actually Duelyst launcher - it does the same for me but I do not have your lag problems.


#3

What’s your GEOGRAPHIC location?


#4

France

The game has very poor performance even in the menu so I doubt it had anything to do with the server or my internet.


#5

Have you looked at point #2 and #3 from here:
https://duelyst.uservoice.com/knowledgebase/articles/893214-poor-frame-rate

Your computer may be using your default processor instead of your dedicated graphics card for running Duelyst. Each video card has an associated application that will allow you to address this (often called a Control Panel). Inside of the application, you will have the option to select specific options specifically for individual programs, and tell Duelyst to always use your dedicated graphics card.

This article will help you navigate the Control Panel that is right for your system: https://support.serato.com/hc/en-us/articles/202305784-Changing-graphics-card-settings-to-use-your-dedicated-GPU-on-a-Windows-computer-

Make sure 3d hardware acceleration is enabled and configured to be used, especially in laptops.

This article will help you find your 3d hardware acceleration options in Windows: http://www.wikihow.com/Turn-off-Hardware-Acceleration

You may also need to enable 3d hardware acceleration through the Control Panel provided by your graphic card’s manufacturer.


#6

It might very well be the answer to my problem thanks a lot


#7

I went on advanced display settings to turn off hardware acceleration , but I don’t even have a troubleshoot tab. Also the tab show the Intel control panel but I have Nvidia Geforce graphic card (don’t know if it matters since I am not supposed to go on this tab anyway)


#8

I’ll have someone from support team help, I’m not entirely sure myself where the settings are on Win 10. But, I’m pretty sure you want to turn hardware acceleration ON not off, am I misreading?


#9

Yeah turn ON sorry . Yeah, if you could ask someone : “why the troubleshoot tab doesn’t appear” that would be great.


#10

If you don’t have a troubleshoot tab, it’s likely your current graphics card doesn’t have drivers that support hardware acceleration in Windows 10. It’ll work in browser because Chrome can force hardware acceleration.

The best thing you can do is try and update the drivers directly from the source – these should be the latest drivers for NVIDIA Win10 64-bit. If those don’t seem to help, unfortunately you may have to play in browser until your card receives a driver update!