Exploit or just a bug?


#1

Description

Describe the issue here.
ok so I joined the Season Ladder queue, found a player, chose my starting hand and clicked “begin” or whatever… when suddenly the opponent moved 2 spaces (he was 1st to start) and ended his turn, all in like 1 second… then it was supposed to be my turn but I couldn’t move, couldn’t put any cards down, until the afk timer went on and it was my opponents turn again… I could see him playing but not normally, like I could see the arrow when you pick and place a card and move it but I couldn’t see what cards he used… THE BOARD WAS EMPTY! I tried using emotes, those seemed to worked normally, my opponent could see them as well as he was taunting me… after some time, everything just stopped, no more afk timers or no more arrows from invisible minions of my opponents, I couldn’t even CONCEDE the game anymore, it was just… frozen… the User Interface was the same the whole time, please check the screenshot:

Operating System:

[Windows / Mac / Linux]
irrelevant

System Specs:

[CPU/GPU/RAM?]
irrelevant

Game Client:

[Standalone/Browser/Steam?]

standalone

Bug Report Details

I don’t have a report
Steps to Reproduce:

  1. …join a game…
  2. …play against a possible cheating bastard…
  3. …cry about it on forum…